Comms errors on GETLOG - SOLVED

Discussion and support for MoTeC's earlier generation ECUs

Comms errors on GETLOG - SOLVED

Postby Flow on Fri Aug 16, 2019 1:52 pm

Hello folks,

I am getting good snappy navigation when connected to the ECU but have only managed to download 69k at the most from a GETLOG. It seems really flaky. I can see that there are numerous updates to for USB to serial compatibility in later versions. Is there anything I can do to tweak my interface settings or EMP config to have GETLOG work reliably on 6.1 or do I need to upgrade the ECU to 6.2 and then the EMP to the latest version? I would prefer to get it working reliably as is first if possible.

EMP 6.13D
ECU M4 1454 6.1
Windows 7 32 bit Virtualbox (not using XP for I2 compatibility)
9600 8 none 1 none, Buffers 64B timers 1ms (I notice that EMP work well at 19200 as well but GETLOG is bad on all settings)

Error examples: 09 03 and 0B so far.
Communications Error 9.JPG
Communications Error 9.JPG (40.53 KiB) Viewed 5571 times

comms error 0B.JPG
comms error 0B.JPG (29.89 KiB) Viewed 5571 times
Last edited by Flow on Sat Aug 17, 2019 6:41 am, edited 1 time in total.
Posts: 14
Joined: Thu Aug 15, 2019 6:21 am

Re: Comms errors on GETLOG

Postby David Ferguson on Fri Aug 16, 2019 11:53 pm

You should try different USB serial adapters. I have had good success using the Keyspan USA-19HS adapter (now sold by TrippLitte). This have diagnostic software available that can help debug serial issues.
David Ferguson
Veracity Racing Data
Check out Shift RPM -
David Ferguson
Pro User
Posts: 1012
Joined: Fri Nov 07, 2008 1:45 am
Location: Paso Robles, California

Re: Comms errors on GETLOG

Postby Flow on Sat Aug 17, 2019 5:40 am

Tanks David, fair suggestion however mine uses the FTDI chipset that has proven rock solid at all baud rates when connecting to console ports of multiple different vendor's network devices and EMPT 6.15 22 Nov 2001 (comes with the 6.13D release) works flawlessly even at 19200.

Additionally from the release notes it looks like Motec added a speed uplift to the comms drivers. GETLOG then ran into problems that they attempted to resolve in the next release.

Do we know what the work around referred to below is and how to implement it?
Am I able to use a later version of the 6.20D comms drivers or GETLOG in the 6.13D suite? If so what is best practice for a hybrid upgrade?

Code: Select all
Faster Comms driver for NT4, Win2000, WinXP included. This works with both standard and USB serial ports.
Utility programs GETLOG, ENABLE, UPGRADE now use new comms driver

Code: Select all
Work around unusual behavior with some USB serial ports. This fixed a problem where utilities such as GETLOG could not communicate with the ECU in some cases
Posts: 14
Joined: Thu Aug 15, 2019 6:21 am

Re: Comms errors on GETLOG - SOLVED

Postby Flow on Sat Aug 17, 2019 6:47 am


I copied the 6.15 EMPT.EXE file into a working 6.20d install to work around the 6.1 <> 6.2 ECU hex to EMPT incompatibility and ended up with GETLOG working a treat even at 19200. Looks like there is definitely an issue with the 6.13D comms drivers that is resolved in 6.20D.

Now is there anyone in the Auckland New Zealand region with an SUU who can help me upgrade the ECU?

GETLOG_Sucess.JPG (36.57 KiB) Viewed 5549 times
Posts: 14
Joined: Thu Aug 15, 2019 6:21 am

Return to M4 and M48 ECUs (including M2R and MLS variants)

Who is online

Users browsing this forum: No registered users and 2 guests