M800 WRX9-10 PROBLEM WITH THE TCK THERMOCUPLE

Covers current and earlier Subaru and Mitsubishi Plug-In systems

M800 WRX9-10 PROBLEM WITH THE TCK THERMOCUPLE

Postby dr350 on Mon May 24, 2021 6:03 am

Hello,

We are working with a Subaru impreza wrx9 with a wrx9-10 plug in m800 board.
We carry out the connections and setup of links according to the technical papers, it says that the type k thermocouple is connected on pins A1 and A2 and we must work with links 4 and 5 open and 21 closed.

We configure the EGT AV7 input, but it is as if we have nothing connected.

We check RAW INPUT VALUES, AND THE VALUE OF AV7 IS 0 volt.

Is there something we are doing incorrectly?

Is there any other configuration missing?

Do all the boards have the TCK amplifier built in?

Thanks, Ragards!
dr350
 
Posts: 25
Joined: Sat Nov 23, 2013 4:35 am

Re: M800 WRX9-10 PROBLEM WITH THE TCK THERMOCUPLE

Postby SprinterTRD on Mon May 24, 2021 8:36 am

That's your problem, The TCK is a extra PCB that gets installed onto the OEM ECU adapter board.

Without it Knock and the thermocouple wont work.
SprinterTRD
Pro User
 
Posts: 354
Joined: Wed Jul 16, 2008 8:24 am

Re: M800 WRX9-10 PROBLEM WITH THE TCK THERMOCUPLE

Postby dr350 on Mon May 24, 2021 10:46 am

SprinterTRD wrote:That's your problem, The TCK is a extra PCB that gets installed onto the OEM ECU adapter board.

Without it Knock and the thermocouple wont work.


Hi,

I thought you could bring the thermocouple amplifier built into the board.

Why do pins A1 and A2 say TC- and TC +?

Thanks,Regards!
dr350
 
Posts: 25
Joined: Sat Nov 23, 2013 4:35 am

Re: M800 WRX9-10 PROBLEM WITH THE TCK THERMOCUPLE

Postby SprinterTRD on Mon May 24, 2021 11:05 am

There is no Thermocouple amplifier built into the adapter board.

The pins marked TC+ & TC- are the connection points to the outside world when you install the TCK board.
SprinterTRD
Pro User
 
Posts: 354
Joined: Wed Jul 16, 2008 8:24 am

Re: M800 WRX9-10 PROBLEM WITH THE TCK THERMOCUPLE

Postby dr350 on Mon May 24, 2021 9:45 pm

SprinterTRD wrote:There is no Thermocouple amplifier built into the adapter board.

The pins marked TC+ & TC- are the connection points to the outside world when you install the TCK board.


Hi,

So you have to connect the thermocouple with TCA AMPLIFIER TO THE AV7 INPUT?

Thanks, regards!
dr350
 
Posts: 25
Joined: Sat Nov 23, 2013 4:35 am

Re: M800 WRX9-10 PROBLEM WITH THE TCK THERMOCUPLE

Postby SprinterTRD on Tue May 25, 2021 1:05 pm

Yes that will work
SprinterTRD
Pro User
 
Posts: 354
Joined: Wed Jul 16, 2008 8:24 am


Return to M800 Plug-In ECUs

Who is online

Users browsing this forum: No registered users and 2 guests