injector open during high load

Discussion and support for MoTeC's previous generation of entry level ECUs

injector open during high load

Postby EagleEyeMotors on Sat Jan 16, 2021 2:12 am

I replaced the LS3 stock injector with Fast 30857-8 Precision-Flow 85lb injector and I face problem that during high load and rpm the injector shows that its open in the ECU but the fuel delivery with wideband meter reading is fine which mean the injector deliver fuel my question is why the ECU shows that the injector is open and how I can solve the problem ?

note that the engine is fit with procharger and it makes 500 hp with the wheels and the maximum fuel pressure is 70 psi (4.7 bar) the fuel pump is connected with regulator and regulator is connected to vacuum line it's controlling the fuel pressure from 3.5 bar to 4.7 bar the maximum injector duty cycle is 70% do you have any suggestion for the fuel system?
EagleEyeMotors
 
Posts: 17
Joined: Sun Oct 29, 2017 12:38 am

Re: injector open during high load

Postby David Ferguson on Sat Jan 16, 2021 3:03 am

According to the help for Diagnostic Error (Operational):

Injector Open indicates an open circuit detected (ie, no current). Possible causes include the Injector Current Setup Parameter IJCU is set too high or the battery voltage is low.

Since your Fast Injectors are high impedance, the parameter Adjust->General Setup->Fuel->Setup->Injector Current should be set to 0.0
David Ferguson
Veracity Racing Data
Check out Shift RPM - https://shiftrpm.veracitydata.com
David Ferguson
Pro User
 
Posts: 1011
Joined: Fri Nov 07, 2008 1:45 am
Location: Paso Robles, California

Re: injector open during high load

Postby EagleEyeMotors on Sat Jan 16, 2021 5:26 am

thanks for your information it's set to 0 before and peak and hold ratio is set to 4 sill facing the same issue
EagleEyeMotors
 
Posts: 17
Joined: Sun Oct 29, 2017 12:38 am

Re: injector open during high load

Postby EagleEyeMotors on Sat Jan 16, 2021 5:48 am

David Ferguson wrote:According to the help for Diagnostic Error (Operational):

Injector Open indicates an open circuit detected (ie, no current). Possible causes include the Injector Current Setup Parameter IJCU is set too high or the battery voltage is low.

Since your Fast Injectors are high impedance, the parameter Adjust->General Setup->Fuel->Setup->Injector Current should be set to 0.0


battery voltage is good I don't think it's the issue from the voltage
EagleEyeMotors
 
Posts: 17
Joined: Sun Oct 29, 2017 12:38 am


Return to M84 ECUs

Who is online

Users browsing this forum: No registered users and 1 guest